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	1
	1
	Productivity Tools
	Word Processing - Importance of word processing
Word Processing - Selecting a tool
	By the end of the lesson, the learner should be able to:
- Explain the meaning of word processing
- Discuss the importance of word processing in document production
- Relate word processing to everyday document needs such as writing letters and reports
	Study handwritten and computer-typed documents and discuss the differences
- Brainstorm on the meaning and importance of word processing
- Use print or digital media to search for the meaning and importance of word processing
	How has word processing transformed the way documents are created and shared in schools?
	Spotlight ICT Grade 10 pg. 60
Digital devices
Sample documents
Internet access
	Oral questions - Observation
Written assignments
	

	
	2
	Productivity Tools
	Word Processing - Creating, saving and closing
Word Processing - Retrieving and editing
	By the end of the lesson, the learner should be able to:
- Create a new text document
- Save, navigate and close a text document
- Value the skill of creating and managing digital documents for personal and academic use
	Launch a word processing application and create a blank document
- Type a letter of appreciation to a teacher and save it using Save As
- Navigate within the document and close it using the File tab
	Why is it important to properly save and organise documents created in a word processor?
	Spotlight ICT Grade 10 pg. 63
Digital devices with word processing software
Internet access
	Practical work - Observation
Oral questions
	

	2
	1
	Productivity Tools
	Word Processing - AutoComplete, AutoCorrect
Find & Replace
	By the end of the lesson, the learner should be able to:
- Enable and use AutoComplete
- Apply Find and Replace to locate and change words or phrases in a document
- Relate these tools to improving efficiency when typing assignments and reports
	Configure AutoCorrect to fix common typing mistakes automatically
- Use Find and Replace to locate specific words and replace them
- Practice editing a document using all three tools
	How can AutoCorrect, AutoComplete and Find & Replace save time when creating documents?
	Spotlight ICT Grade 10 pg. 69
Digital devices with word processing software
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Word Processing - Formatting paragraphs
Formatting columns and page layout
	By the end of the lesson, the learner should be able to:
- Apply paragraph alignment and line spacing
- Format text using bullets, numbering and tab stops
- Connect paragraph formatting skills to organizing content neatly
	Align text using Left, Centre, Right and Justify options
- Adjust line spacing, space before and after paragraphs, and indentation
- Apply bullets and numbering and insert tab stops using the ruler
	What role does paragraph formatting play in making documents neat and professional?
	Spotlight ICT Grade 10 pg. 75
Digital devices with word processing software
	Practical work - Observation
Oral questions
	

	3
	1
	Productivity Tools
	Word Processing - Inserting symbols, shapes and images
	By the end of the lesson, the learner should be able to:
- Insert and format symbols, shapes and images
- Apply text wrap and crop images in a document
- Relate inserting graphics to designing real-life documents such as posters and flyers
	Insert symbols and customize shapes using the Shape Format tab
- Insert images from device or online sources and resize using object handles
- Apply text wrap styles to images and shapes and crop images
	How do graphics such as symbols, shapes and images enhance visual appeal?
	Spotlight ICT Grade 10 pg. 88
Digital devices
Sample images for insertion
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Word Processing - Table of figures and table of contents
	By the end of the lesson, the learner should be able to:
- Add captions to images and insert a table of figures
- Apply heading styles and insert a table of contents
- Relate these features to organizing large documents like research reports
	Add captions to figures using the References tab and Insert Caption
- Insert and update a table of figures
- Apply heading styles to document headings and insert a table of contents
	Why is a table of contents important in long documents such as books and research papers?
	Spotlight ICT Grade 10 pg. 93
Digital devices
Internet access
	Practical work - Observation
Written assignments
	

	4
	1
	Productivity Tools
	Word Processing - Section breaks, page breaks and styles
	By the end of the lesson, the learner should be able to:
- Insert section breaks and page breaks
- Apply, modify and create custom styles in a document
- Relate the use of breaks and styles to structuring documents like project reports
	Search for the meaning of section break and page break using digital media
- Insert section breaks and page breaks using the Layout tab
- Apply built-in styles from the Home tab and modify existing styles
	How do section breaks, page breaks and styles help in organizing a well-structured document?
	Spotlight ICT Grade 10 pg. 99
Digital devices with word processing software
Internet access
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Word Processing - Headers, footers, hyperlinks and cross-referencing
	By the end of the lesson, the learner should be able to:
- Insert headers and footers
- Insert hyperlinks and cross-references in a document
- Connect these features to linking web resources and adding page identifiers
	Search for the meaning of headers, footers and hyperlinks
- Insert and customize headers and footers using the Insert tab
- Insert hyperlinks to files, web pages, and email addresses
	How do hyperlinks and cross-references improve navigation in digital documents?
	Spotlight ICT Grade 10 pg. 104
Digital devices with word processing software
Internet access
	Practical work - Observation
Written assignments
	

	5
	1
	Productivity Tools
	Word Processing - Creating and manipulating tables
	By the end of the lesson, the learner should be able to:
- Create, format and edit tables
- Sort data, merge and split cells in a table
- Relate table creation skills to organizing data in timetables and inventory lists
	Create tables using the Insert tab and Draw Table feature
- Format tables using Table Design and Table Layout tabs
- Insert and delete rows and columns, merge cells, and sort data
	How are tables useful in organizing and presenting data in documents?
	Spotlight ICT Grade 10 pg. 108
Digital devices with word processing software
	Practical work - Observation
Oral questions - Written assignments
	

	
	2
	Productivity Tools
	Word Processing - Generating merged documents using mail merge
	By the end of the lesson, the learner should be able to:
- Create a main document and a data source
- Generate merged documents using mail merge features
- Relate mail merge to real-life applications like sending personalized invitation letters
	Search for the meaning of mail merge, main document and data source
- Create a main document and start mail merge using the Mailings tab
- Insert merge fields, preview, and merge documents for printing or emailing
	How does mail merge simplify the process of sending personalized documents to many people?
	Spotlight ICT Grade 10 pg. 113
Digital devices with word processing software
	Practical work - Observation
Project
	

	6
	1
	Productivity Tools
	Word Processing - Collaborating with track changes, comments and sharing
	By the end of the lesson, the learner should be able to:
- Use track changes and comments to collaborate
- Share a document through hard copy, PDF, email or upload
- Relate collaboration tools to group projects and peer review


	Enable Track Changes in the Review tab and make edits on a shared document
- Accept or reject tracked changes and insert/reply to comments
- Share a document as a hard copy, save as PDF, and upload to Google Drive
	Why is collaboration important when working on shared documents in school?
	Spotlight ICT Grade 10 pg. 114
Digital devices
Printer
Internet access
	Practical work - Observation
Oral questions - Portfolio
	

	
	2
	Productivity Tools
	Word Processing - Collaborating with track changes, comments and sharing
	By the end of the lesson, the learner should be able to:
- Use track changes and comments to collaborate
- Share a document through hard copy, PDF, email or upload
- Relate collaboration tools to group projects and peer review

	Enable Track Changes in the Review tab and make edits on a shared document
- Accept or reject tracked changes and insert/reply to comments
- Share a document as a hard copy, save as PDF, and upload to Google Drive
	Why is collaboration important when working on shared documents in school?
	Spotlight ICT Grade 10 pg. 114
Digital devices
Printer
Internet access
	Practical work - Observation
Oral questions - Portfolio
	

	7
	1
	Productivity Tools
	Word Processing - Appreciating the role of productivity tools
	By the end of the lesson, the learner should be able to:
- Create a community newsletter using word processing
- Practice word processing skills such as creating letters and posters
- Relate word processing to community engagement
	Visit the community or school to gather information for a newsletter
- Create a community newsletter incorporating text, images, formatting and layout
- Share newsletters through print, PDF, email or digital platforms
	How can word processing skills be used to serve and inform the community?
	Spotlight ICT Grade 10 pg. 116
Digital devices
Printer
Internet access
	- Project - Portfolio
- Peer assessment - Rubrics
	

	
	2
	Productivity Tools
	Presentation - Selecting a presentation tool
Creating and editing
	By the end of the lesson, the learner should be able to:
- Identify examples of presentation software
- Select a suitable presentation productivity tool
- Relate the choice of presentation software to academic and professional needs
	Search for information on examples of presentation software and their features
- Identify icons such as MS PowerPoint, Google Slides, LibreOffice Impress
- Visit the school computer lab to explore available presentation software
	What features make a presentation software suitable for creating engaging presentations?
	Spotlight ICT Grade 10 pg. 120
Digital devices with presentation software
	Oral questions - Observation
Written assignments
	

	8
	                                                                MID TERM

	9
	1
	Productivity Tools
	Presentation - Adding tables in a presentation
Adding and customizing charts
	By the end of the lesson, the learner should be able to:
- Insert and format a table in a presentation slide
- Enter and organize data in a table
- Connect table skills to displaying organized data such as survey results
	Add a new slide and insert a table using the Insert tab
- Specify the number of rows and columns and enter data
- Format the table and adjust cell sizes, align text
	How do tables help present data clearly in a presentation?
	Spotlight ICT Grade 10 pg. 127
Digital devices with presentation software
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Presentation - Inserting shapes and adding speaker notes
	By the end of the lesson, the learner should be able to:
- Insert and customize shapes in a presentation
- Add speaker notes to slides for use during delivery
- Relate speaker notes to real-world public speaking situations
	Insert shapes using the Insert tab and Illustrations group
- Customize shapes by changing fill color, outline and effects
- Add speaker notes in the Notes pane and enable Presenter View
	How do shapes and speaker notes improve the quality and delivery of a presentation?
	Spotlight ICT Grade 10 pg. 134
Digital devices with presentation software
	Practical work - Observation
Oral questions
	

	10
	1
	Productivity Tools
	Presentation - Inserting multimedia elements
Creating master slides
	By the end of the lesson, the learner should be able to:
- Insert audio and video files into presentation slides
- Identify different types of multimedia elements
- Relate multimedia integration to creating engaging presentations
	Search for the meaning and types of multimedia elements
- Insert audio and video files into a slide using the Insert tab
- Play and preview multimedia elements within slides
	How does adding audio and video to a presentation make it more engaging?
	Spotlight ICT Grade 10 pg. 137
Digital devices
Audio and video files
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Presentation - Adding hyperlinks to slides
	By the end of the lesson, the learner should be able to:
- Insert hyperlinks to web pages, other slides and files
- Navigate between slides using hyperlinks
- Connect hyperlink skills to creating interactive digital resources
	Select text, image or shape and insert a hyperlink using the Insert tab
- Link to another slide within the same presentation
- Set up an email hyperlink and test hyperlinks during the presentation
	How do hyperlinks enhance interactivity and navigation in a presentation?
	Spotlight ICT Grade 10 pg. 141
Digital devices
Internet access
	Practical work - Observation
Written assignments
	

	11
	1
	Productivity Tools
	Presentation - Applying animations to text and objects
	By the end of the lesson, the learner should be able to:
- Apply animations to text, images and shapes
- Customize animation effects and sequences
- Relate animations to capturing audience attention in real scenarios

	Search for the meaning of animation in presentations
- Select an object and apply animations such as Appear, Fade, Fly In from the Animations tab
- Customize movement sequences and preview animation order
	How do animations help capture and maintain the audience's attention?
	Spotlight ICT Grade 10 pg. 144
Digital devices with presentation software
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Presentation - Applying slide transition effects
	By the end of the lesson, the learner should be able to:
- Apply transition effects between slides
- Adjust transition speed, add sound effects and set automatic slide advancement
- Relate transitions to creating smooth, professional presentations
	Click on a slide and apply a transition effect from the Transitions tab
- Adjust transition duration for slower or faster effects
- Set slides to advance automatically by unchecking On Mouse Click
	What is the difference between slide transitions and animations in a presentation?
	Spotlight ICT Grade 10 pg. 145
Digital devices with presentation software
	Practical work - Observation
Oral questions
	

	12
	1
	Productivity Tools
	Presentation - Presenting slides and using presenter tools
	By the end of the lesson, the learner should be able to:
- Present slides using Slide Show mode and Presenter View
- Navigate through slides during a presentation
- Relate presentation delivery skills to real-life situations
	Start a slide show from the beginning or from the current slide
- Enable and use Presenter View to view notes and upcoming slides
- Navigate between slides using arrow keys and end the presentation
	How does Presenter View help a speaker deliver a more confident presentation?
	Spotlight ICT Grade 10 pg. 146
Digital devices with presentation software
Projector
	Practical work - Observation
Oral questions
	

	
	2
	Productivity Tools
	Presentation - Delivering a presentation on a topical issue to the community
	By the end of the lesson, the learner should be able to:
- Create a complete presentation on a topical issue
- Deliver a presentation effectively to an audience
- Connect presentation skills to raising awareness on community issues
	Identify a community issue and gather information to create an outline
- Create a professional presentation incorporating all features (text, charts, hyperlinks, animations)
- Practice delivery, present to schoolmates, and gather feedback
	How can presentation skills be used to educate and engage the community?
	Spotlight ICT Grade 10 pg. 144
Digital devices
Projector
Internet access
	- Project - Rubrics
- Peer assessment - Portfolio
	

	13-14
	
[bookmark: _GoBack]                                                                      REVISION/END OF TERM ASSESSMENT



































